使用 Microsoft 登录
登录或创建帐户。
你好,
使用其他帐户。
你有多个帐户
选择要登录的帐户。

问题

如果尝试使用社区虚拟驱动程序重置 (清除) 虚拟磁盘,则可能会重置错误的磁盘。 你将收到错误消息:“找到多个 ID 相同的磁盘。 请更新存储驱动程序,然后重试。

无法重置磁盘

原因

使用社区虚拟驱动程序时,有些虚拟磁盘可能具有相同的 UniqueId。 这可能会在启动重置操作时造成问题。 重置操作将重置它找到的第一个磁盘。 但是,这可能不是要重置的磁盘。 因此,该磁盘将丢失数据。

解决方法/解决方法

可以使用下面的 PowerShell 命令检索和重置 (清除磁盘) 。

  1. 若要检索有关磁盘的详细信息,请键入Get-PhysicalDisk |Select-Object -Property FriendlyName、DeviceID、UniqueId

  2. 确认要重置的磁盘的详细信息。 在命令中使用磁盘的 DeviceId 作为 数字 :Clear-Disk [-Number] <UInt32[]>

详细信息

有关详细信息,请参阅 Get-PhysicalDiskClear-Disk

需要更多帮助?

需要更多选项?

了解订阅权益、浏览培训课程、了解如何保护设备等。

社区可帮助你提出和回答问题、提供反馈,并听取经验丰富专家的意见。

此信息是否有帮助?

你对语言质量的满意程度如何?
哪些因素影响了你的体验?
按“提交”即表示你的反馈将用于改进 Microsoft 产品和服务。 你的 IT 管理员将能够收集此数据。 隐私声明。

谢谢您的反馈!

×